Bug with Google WebService

More
7 months 1 week ago #3427 by chemin
Hello, i have a little bug with I2 and Google :

- The curent Google WebService is not supported.
Please delete the WebService from the Google Drive and install the latest version.

If someone can help me

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #3428 by Frank
Replied by Frank on topic Bug with Google WebService
Hi,
If you was using an old version of the plugin (it may have installed the WebService v3).
Several months ago, the plugin started using WebService v4.

If you had the old plugin installed,and recently updated to the latest version, then the v3 WebService will not work correctly.
You will have to delete it from your Google Drive, and from the new plugin, click "Instal" again. That will copy v4 into your GoogleDrive. Then, just follow the steps to deploy it and get a new URL.

Hope that helps,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #3429 by chemin
Replied by chemin on topic Bug with Google WebService
Thanks for your reply Franck ;)

I have WebService V5 - I'm working with Atavism Online, i have delete I2 - delete all data on GoogleDrive but same errors :'(

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #3437 by Frank
Replied by Frank on topic Bug with Google WebService
Hi,
I have been apptemting a few times to reproduce that issue, but haven't been able to.
I have tried clean instalations in differrent computers, but if all the steps are followed, I always get a valid WebService.

Some ideas:
- Can you double check that you didn't change the WebService password (either in the WebService code or the I2Languages.asset)?

- When deploying the WebService, did the authorization steps finished correctly?

- Are you logged to more than one google account at the same time in your browser? If so, please, verify that when installing the service, the account 0 is the one doing the instalation.

If that doesn't help,
Can you please describe the steps you follow to delete the current WebService, and reinstall it, and then to verify in Unity that it is not supported. (Or even email me a video if thats easiest)
I may be missing something.

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago - 7 months 6 days ago #3442 by chemin
Replied by chemin on topic Bug with Google WebService
Hi :)
I have only 1 account connected at the moment
Unity version : 2018.3.2f1

1 - Click on install
2 - Change password
3 - Deploy
4 - Execute (DoGet)
5 - Paste the url and change the password

i don't know why .... :(
i have Teamviewer if you need to try
Attachments:
Last edit: 7 months 6 days ago by chemin.

Please Log in or Create an account to join the conversation.

More
7 months 6 days ago - 7 months 6 days ago #3443 by Frank
Replied by Frank on topic Bug with Google WebService
Hi,
All the steps you are describing seem to be fine. But there is one thing I noticed that may be the cause of this issue.
In the 2.PNG image you attached, the settings for Who can access the WebService seems wrong:
It should be "Anyone, even anonymous", not "only me"

inter-illusion.com/assets/I2Localization...gleSpreadsheets.html
inter-illusion.com/assets/I2Localization...ogleSpreadsheet.html

The Unity Editor and your deployed game doesn't have your google credentials so it has to access the webservice as an anonymous. Thats why we have a password field, and only allow accessing "spreadsheets that start with I2Loc", so that there no risk of hackers accessing any other info in your drive.

Hope that helps,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last edit: 7 months 6 days ago by Frank.

Please Log in or Create an account to join the conversation.

Time to create page: 0.235 seconds
Template by JoomlaShine