Welcome, Guest
Username: Password: Remember me

TOPIC: Bug with Google WebService

Bug with Google WebService 1 week 3 days ago #3427

  • chemin
  • chemin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Hello, i have a little bug with I2 and Google :

- The curent Google WebService is not supported.
Please delete the WebService from the Google Drive and install the latest version.

If someone can help me
The administrator has disabled public write access.

Bug with Google WebService 1 week 3 days ago #3428

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1169
  • Thank you received: 253
  • Karma: 77
Hi,
If you was using an old version of the plugin (it may have installed the WebService v3).
Several months ago, the plugin started using WebService v4.

If you had the old plugin installed,and recently updated to the latest version, then the v3 WebService will not work correctly.
You will have to delete it from your Google Drive, and from the new plugin, click "Instal" again. That will copy v4 into your GoogleDrive. Then, just follow the steps to deploy it and get a new URL.

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.

Bug with Google WebService 1 week 3 days ago #3429

  • chemin
  • chemin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Thanks for your reply Franck ;)

I have WebService V5 - I'm working with Atavism Online, i have delete I2 - delete all data on GoogleDrive but same errors :'(
The administrator has disabled public write access.

Bug with Google WebService 6 days 17 hours ago #3437

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1169
  • Thank you received: 253
  • Karma: 77
Hi,
I have been apptemting a few times to reproduce that issue, but haven't been able to.
I have tried clean instalations in differrent computers, but if all the steps are followed, I always get a valid WebService.

Some ideas:
- Can you double check that you didn't change the WebService password (either in the WebService code or the I2Languages.asset)?

- When deploying the WebService, did the authorization steps finished correctly?

- Are you logged to more than one google account at the same time in your browser? If so, please, verify that when installing the service, the account 0 is the one doing the instalation.

If that doesn't help,
Can you please describe the steps you follow to delete the current WebService, and reinstall it, and then to verify in Unity that it is not supported. (Or even email me a video if thats easiest)
I may be missing something.
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.

Bug with Google WebService 4 days 22 hours ago #3442

  • chemin
  • chemin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Hi :)
I have only 1 account connected at the moment
Unity version : 2018.3.2f1

1 - Click on install
2 - Change password
3 - Deploy
4 - Execute (DoGet)
5 - Paste the url and change the password

i don't know why .... :(
i have Teamviewer if you need to try
Attachments:
Last Edit: 4 days 22 hours ago by chemin.
The administrator has disabled public write access.

Bug with Google WebService 4 days 20 hours ago #3443

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1169
  • Thank you received: 253
  • Karma: 77
Hi,
All the steps you are describing seem to be fine. But there is one thing I noticed that may be the cause of this issue.
In the 2.PNG image you attached, the settings for Who can access the WebService seems wrong:
It should be "Anyone, even anonymous", not "only me"

inter-illusion.com/assets/I2Localization...gleSpreadsheets.html
inter-illusion.com/assets/I2Localization...ogleSpreadsheet.html

The Unity Editor and your deployed game doesn't have your google credentials so it has to access the webservice as an anonymous. Thats why we have a password field, and only allow accessing "spreadsheets that start with I2Loc", so that there no risk of hackers accessing any other info in your drive.

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last Edit: 4 days 20 hours ago by Frank.
The administrator has disabled public write access.
Time to create page: 0.113 seconds
Template by JoomlaShine