Problem with SpreadSheet install.

More
1 year 6 months ago - 1 year 6 months ago #2596 by Cvita
I had a version from few months ago installed.
Today I updated the package (before the latest one).
Then it didn't work (like I mentioned).
30 mins ago - I updated the package to latest one.
Now the error that ScriptLocalize is no longer existing. So I converted all calls to LocalizeManager.GetTranslation()
Now the same error appears (Unable to access the WebService) in Unity (but I do get v5 script in GoogleScript).
Now also, the dropdown for Tools->I2 doesn't show 'show localization object'.

Also maybe worth noting - when I run doGet nothing happens (at least I don't see any notifications).

So yea... I don't think I did anything special. But it doesn't work. And my progress is stalled :/


UPDATE: I removed the I2 folder with all files. I reimported. Tried installing again - no success. Everything the same. "Unable to access the WebService".
Unable to access the WebService
UnityEngine.Debug:LogError(Object)
I2.Loc.LocalizationEditor:ShowMessage(String, MessageType, Boolean) (at Assets/I2/Localization/Scripts/Editor/Localization/LocalizationEditor.cs:215)
I2.Loc.LocalizationEditor:ShowError(String, Boolean) (at Assets/I2/Localization/Scripts/Editor/Localization/LocalizationEditor.cs:200)
I2.Loc.LocalizationEditor:OnVerifyGoogleService(String, String) (at Assets/I2/Localization/Scripts/Editor/Localization/LocalizationEditor_Spreadsheet_Google.cs:378)
I2.Loc.LocalizationEditor:CheckForConnection() (at Assets/I2/Localization/Scripts/Editor/Localization/LocalizationEditor_Spreadsheet_Google.cs:490)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()
Last edit: 1 year 6 months ago by Cvita.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #2597 by Mojo
Hi everyone,
so I was using v2.8.0.3 and the service was v4.
I updated to the new version using v5...and have the exact same problem, and it's a crash :
Unable to access the WebService

Here is the value of Result that is parsed in OnVerifyGoogleService => var data = SimpleJSON.JSON.Parse(Result).AsObject, I replaced some values with ...

<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta name="robots" content="noindex">
<title>Sign in - Google Accounts</title>
<meta http-equiv="refresh" content="1; url=https://www.google.com/accounts/AccountChooser?hd=blabla.com&amp;continue=https%3A%2F%2Fscript.google.com%2Fa%2Fblabla.com%2Fmacros%2Fs%...%2Fexec%3Faction%3DPing&amp;followup=https%3A%2F%2Fscript.google.com%2Fa%2Fblabla.com%2Fmacros%2Fs%...%2Fexec%3Faction%3DPing&amp;service=wise"></meta>
</head>
<body >
<form id="hiddenget" action=" www.google.com/accounts/AccountChooser?h...ing&service=wise " method="get">
<noscript>
You should turn on Javascript support.
<input type="submit" id="nojssubmit" value="Continue">
</noscript>
</form>
<script nonce="...">
window.onload = function() {
....
}
window.location.replace(redirectUrl);
};
</script>
</body>
</html>


and the error message when parsing the version number => int version = int.Parse(data["script_version"]);

Unable to access the WebService
0x00000001412F1EB6 (Unity) StackWalker::GetCurrentCallstack
0x00000001412F2A2F (Unity) StackWalker::ShowCallstack
0x00000001411B1840 (Unity) GetStacktrace
0x00000001406DA5D3 (Unity) DebugStringToFile
0x00000001406DADB1 (Unity) DebugStringToFile
0x000000014142B4C2 (Unity) DebugLogHandler_CUSTOM_Internal_Log
0x00000000393B1B4B (Mono JIT Code) (wrapper managed-to-native) UnityEngine.DebugLogHandler:Internal_Log (UnityEngine.LogType,string,UnityEngine.Object)
0x00000000393B19A4 (Mono JIT Code) [DebugLogHandler.cs:9] UnityEngine.DebugLogHandler:LogFormat (UnityEngine.LogType,UnityEngine.Object,string,object[])
0x00000000393B12A5 (Mono JIT Code) [Logger.cs:47] UnityEngine.Logger:Log (UnityEngine.LogType,object)
0x000000003E403573 (Mono JIT Code) [DebugBindings.gen.cs:124] UnityEngine.Debug:LogError (object)
0x000000003E4650B2 (Mono JIT Code) [LocalizationEditor.cs:215] I2.Loc.LocalizationEditor:ShowMessage (string,UnityEditor.MessageType,bool)
0x000000003E8492B5 (Mono JIT Code) [LocalizationEditor.cs:200] I2.Loc.LocalizationEditor:ShowError (string,bool)
0x000000003E8456E3 (Mono JIT Code) [LocalizationEditor_Spreadsheet_Google.cs:378] I2.Loc.LocalizationEditor:OnVerifyGoogleService (string,string)
0x000000003E841D6E (Mono JIT Code) [LocalizationEditor_Spreadsheet_Google.cs:490] I2.Loc.LocalizationEditor:CheckForConnection ()
0x000000003B97BE90 (Mono JIT Code) (wrapper delegate-invoke) UnityEditor.EditorApplication/CallbackFunction:invoke_void__this__ ()
0x000000003E3F6049 (Mono JIT Code) [EditorApplication.cs:127] UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
0x0000000012B311DE (Mono JIT Code) (wrapper runtime-invoke) object:runtime_invoke_void (object,intptr,intptr,intptr)
0x00007FF8F30464AF (mono) [mini.c:4937] mono_jit_runtime_invoke
0x00007FF8F2F98A19 (mono) [object.c:2623] mono_runtime_invoke
0x00000001407EBA99 (Unity) mono_runtime_invoke_profiled
0x0000000140A218BE (Unity) CallStaticMonoMethod
0x0000000140A219CF (Unity) CallStaticMonoMethod
0x0000000140A22A41 (Unity) CallStaticMonoMethod
0x0000000141186DD3 (Unity) SceneTracker::Update
0x00000001411EA19F (Unity) Application::TickTimer
0x000000014140F8FF (Unity) MainMessageLoop
0x00000001414111A5 (Unity) WinMain
0x0000000141E5DAB8 (Unity) __tmainCRTStartup
0x00007FF9220A2774 (KERNEL32) BaseThreadInitThunk
0x00007FF924000D51 (ntdll) RtlUserThreadStart

Last edit: 1 year 6 months ago by Mojo.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #2599 by Frank
Hi,
Thanks for sharing the returned html!
That seems to indicate that WebService was not installed and authorized properly, given that its requiring you to sign in again to one of your accounts.

My advice is to open your browser,
Log off from ALL your google accounts (in case you have several opened at the same time),
then Log in to the one you are planning to use
And click the install button in Unity.

I made this video showing the steps I'm using to install and authorize the plugin:


Another thought: Its the account you are using a work or personal account? Some work account may add restriction to your access.
If following the steps in the video doesn't solve the issue, can someone please, make a video of their setup. That will help me figure out what's happening!

Thanks a lot, and sorry for this troubles!
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last edit: 1 year 6 months ago by Frank.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #2600 by Cvita
Thanks for your assistance Frank.

I logged out all of my google accounts - no success. I do everything like you do in the video.

Question - do I have to update from 2.8 and V4 script to latest?

I mean, it doesn't matter (I tried both and it didn't work with my project).

I could potentially show you HTML log if you tell me how to get it?

Thanks

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #2601 by Mojo
Hi Frank,
yes it's a work account, and it's still not working after exiting the google account. Everything is fine and works as in your video(except the warning). The authorisation is asked, the link created, the project is correctly deployed as a web app, with a link. the But the verify still fails.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #2603 by Cvita
Well, I fixed my problem!
I think it was caused by some stuff I added to my hosts file (MacOS).
After removing a lot of redirects (was avoiding some ads from being loaded), and flushing cache (dscacheutil -flushcache;sudo killall -HUP mDNSResponder), everything works again!

Hope it helps someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 1.081 seconds
Template by JoomlaShine