Welcome, Guest
Username: Password: Remember me

TOPIC: Long Text not Spaced

Long Text not Spaced 1 week 3 days ago #2485

  • CK247
  • CK247's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi Frank,
There is a problem with the Chinese(Traditional), Chinese(Simplified), and Japanese translations. When these three languages are translated, They become long and not spaced which makes it very difficult to read. This does not happen in any of the other languages except these three. In the attachment named In English, you will see the original text nicely spaced and adjusted.




However, the text is squished into one long line instead of the multiple lines.





This problem is resolved when I manually space every character in that text out.




Also how do I export the current translations that I have and import them back to them use them as local spreadsheet instead of live Google translations?
Attachments:
The administrator has disabled public write access.

Long Text not Spaced 1 week 2 days ago #2491

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 873
  • Thank you received: 189
  • Karma: 55
Hi,
Some languages like Chinese, Japanese and Thai, don't add spaces between words. That's why the translations show all characters together.
Most UI systems (like Unity UI) process this fine and wrap those characters even when they don't have spaces. But I'm guessing some other targets may not be doing that correctly.

To bypass this problem, I just added a checkbox that allows adding spaces to those languages (this can be set per-label in order to avoid it when the text is small). That should allow you to wrap the text in any target that doesn't do the wrapping correctly.

If you download v2.8.0f2 from the beta folder, you will see the checkbox in the Localize component. If you enable it, the characters will be separated.





Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.

Long Text not Spaced 1 week 2 days ago #2492

  • CK247
  • CK247's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Hi, Frank
I don't know if I did this wrong but I did not know where to find the beta folder so I went to the asset store and updated the I2 program. It was able to update but it came up with this error after the update:

In the console:


In the script:





I think I fixed the error, which was coming from the "GetTermTranslation" to just "GetTranslation" and it worked fine with no error.





I am not sure if this is the right way to do it but I hope that fixed it. Also I do not see the "Separate Words" check box on the inspector:




I am not sure if using unity asset store to update it was the right way.
The administrator has disabled public write access.

Long Text not Spaced 1 week 1 day ago #2493

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 873
  • Thank you received: 189
  • Karma: 55
Hi,
I did not know where to find the beta folder so I went to the asset store and updated the I2 program

Version 2.8.0f2 is not yet in the assetstore, I'm planning in releasing it on Monday, but it will take a few days for the AssetStore team to approve it.
Said that, you can download it right away, by accessing the beta folder, here is how:
inter-illusion.com/forum/i2-localization...ssing-early-versions
It was able to update but it came up with this error after the update

Yes, the latest version, renamed that function to make it more consistent, and simply the optional parameters.
Renaming the function as you did will fix the problem. The other solution is to delete ScriptLocalization.cs, that file is auto-generated and the next time you use the Bake Terms Tool, it will be generated with the correct methods. Nonetheless, if you are not using baked terms, then deleting ScriptLocalization.cs will not affect anything else.

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.
The following user(s) said Thank You: CK247

Long Text not Spaced 1 week 1 day ago #2494

  • CK247
  • CK247's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Works like a charm. Thanks.
The administrator has disabled public write access.
Time to create page: 0.100 seconds
Colors