Welcome, Guest
Username: Password: Remember me

TOPIC: Translate stops at "&"

Translate stops at "&" 2 months 3 weeks ago #2449

  • nowISnow
  • nowISnow's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
If I use the "Translate" button and there is an & in my text, the translations stops there.
Attachments:
Last Edit: 2 months 3 weeks ago by nowISnow. Reason: added picture
The administrator has disabled public write access.

Translate stops at "&" 2 months 3 weeks ago #2451

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 915
  • Thank you received: 196
  • Karma: 58
Hi,
Thanks for letting me know about this issue!
It is now fixed in 2.8.0b6.

To fix it locally, you can replace the line 139 in the file assets\i2\localization\scripts\google\googletranslation.cs
with this one:
	string url = string.Format("{0}?action=Translate&list={1}:{2}={3}", LocalizationManager.GetWebServiceURL(), LanguageCodeFrom, LanguageCodeTo, Uri.EscapeDataString( text ));

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last Edit: 2 months 3 weeks ago by Frank.
The administrator has disabled public write access.

Translate stops at "&" 2 months 3 weeks ago #2456

  • nowISnow
  • nowISnow's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Thanks! Was line 128 for me, but its working now B)
The administrator has disabled public write access.
Time to create page: 0.226 seconds
Colors