Issue with Chinese and Android and IOS in Unity 5

More
4 years 2 months ago #883 by rall117
Hello,

First:
I'm using the version of I2 2.5.0 f1 with Unity 5.1.2f1

I'm using the Unity 5 UI System, and all kind of languages are working perfect running on Android 4.4.2 and on IOS 8.2 like Japanese, Korean, Russian, etc
but any Chinese "zh" "zh-CN", etc, doesn't work, only if I set it up as the first on the languages list on I2 Languages it is displayed on the devices, but I need my base language to be english and not chinese, if I put it down on the list it doesn't work any more on the devices.

It is not an issue with the dynamic fond because as I said it works as default language, please check out where the problem is, and how can be fix it.
Thanks a lot :cheer:

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #884 by Frank
Hi,
I'm trying to reproduce the issue but it seems to be working fine for me.

What do you mean by 'any Chinese "zh" "zh-CN", etc, doesn't work'?

I took the UnityStandard Localization scene and added a new language Chinese Simplified "zh-CN". The language was at the end of the language list.
Then I auto-translated all the terms for the new language and changed a button to switch into zh-CN.

Whenever I clicked the button, the language was changed to the chinese and I was seeing all text with the correct Chinese translation.

Can you please, list some steps that make the UnityStandard Localization scene fail, so that I could try it over here?
Just in case, Did you meant that the plugin wasn't able to detect Chinese from the device language or that you couldn't set chinese from your game with a button/popup?

Also, can you download the latest version (2.6.0 b3). There were some fixes and improvements in the languages and general localization settings that may have fixed the issue you are seeing.

Thanks,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #885 by rall117
Hello, Thanks for your quick reply B)

I did all you did and it is correct all works the way you did, but I'm using auto detection when the app's launch, so the real issue is the plugin wasn't able to detect Chinese from the device language, sorry I didn't explaint it before.

Maybe I can may try the beta version, how can I get it?
Thanks a lot :cheer:

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #886 by Frank
Ahh, I see, I will try that now.

If you email me your unity invoice number I can add you the beta community and from there you can download any versions, including those that are not yet in the AssetStore :-)

Thanks,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #887 by Frank
Hi,
I found the issue :woohoo: , Unity 5 added some changes to report the Chinese language with Traditional/Simplified.
The plugin now detects that and selects the correct language in your languageSource.

The fix is in version 2.6.0 b4. You can download it now from the beta community folder.

Thanks,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The following user(s) said Thank You: rall117

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #888 by adamliu
Hi Frank, please add me to the beta community where I can download the beta versions, I just bought the plugin today and I encountered the same bug mentioned here. I'll email you my invoice, can you tell me your email address?
:( :(

Frank wrote: Hi,
I found the issue :woohoo: , Unity 5 added some changes to report the Chinese language with Traditional/Simplified.
The plugin now detects that and selects the correct language in your languageSource.

The fix is in version 2.6.0 b4. You can download it now from the beta community folder.

Thanks,
Frank

Please Log in or Create an account to join the conversation.

Time to create page: 1.198 seconds
Template by JoomlaShine