Preview on Designtime

More
4 years 4 months ago #864 by wagenheimer
On 2.6.0 b1 version I cannot preview the translation on design time anymore.

Has the way of doing it changed?

Thanks

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #866 by Frank
Replied by Frank on topic Preview on Designtime
2.6.0 b1 added a feature to tag translations as been set by a Human or by Google Translator (so that this auto-translated could be found later on and approved).

However, you should see the translations in the editor normally. If not, its a bug! :blink:

Can you tell me how I can reproduce that error.

Did you just updated and when opened the editor it doesn't show anything?
Or did you imported from google?
Are you seeing any error/warning in the console?

Thanks,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last edit: 4 years 4 months ago by Frank.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #867 by wagenheimer
Replied by wagenheimer on topic Preview on Designtime
I updated the old version to this one, and it seems to be not showing any error.

I have an Localize component on a TextMeshPro, I have the term "cardbacks" selected on it, and so I click on the "English" translation of it, and then I click on "Scene" or "Game Window". Until the last version I was able to see the translation on the label, now nothing changes.

Any more info?

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #869 by wagenheimer
Replied by wagenheimer on topic Preview on Designtime
It seems the varialble mLanguageSource is null... The translate buttons also does not works when I select the label.

But If I select the i2 prefab, the Translate Buttons seems to work.

Another problem, the resulting Google Spreadsheet, give me some rows with error on this code : =GOOGLETRANSLATE(A6,"auto","en")

Thanks for the help!

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #870 by Frank
Replied by Frank on topic Preview on Designtime
Hi,
I just verified version 2.6.0 b1 and the text is changing for the TextMesh Pro. :blink:

What I guess is happening is that the defines to enable TMP are missing from your Build Settings.
You should add: TextMeshPro;TMProBeta

This defines are automatically detected by the plugin (unless auto-detection is disabled)
You can also force the auto detection by executing the menu Tools/I2 Localization/Enable Plugins/Force Detection

That will add the correct defines based on the plugins it detects on your project.

Hope that helps, and if the problem persist, can you tell me which version of TMP are you using, so that I could test in that version.

Thanks
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #871 by Frank
Replied by Frank on topic Preview on Designtime

Another problem, the resulting Google Spreadsheet, give me some rows with error on this code : =GOOGLETRANSLATE(A6,"auto","en")


Can you please email me a section of the spreadsheet that is giving you error. If I'm able to reproduce it I will fix it and update asap.

Thanks!
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
Last edit: 4 years 4 months ago by Frank.

Please Log in or Create an account to join the conversation.

Time to create page: 0.287 seconds
Template by JoomlaShine