Installation of 2.8.9 f1 not working

More
8 months 4 hours ago #3298 by kevinbedard
Hey everyone, I just purchased I2 Localization and looking forward into using it. The documentation is really outdated though regarding the install, so I figured I was going to come in here and ask for help.

First of all I have 2 compiler error right of the bat as I import the plugin into my project:

Assets/I2/Localization/Examples/Common/Scripts/RealTimeTranslation.cs(15,84): error CS0117: `Screen' does not contain a definition for `width'

Assets/I2/Localization/Examples/Common/Scripts/RealTimeTranslation.cs(32,71): error CS0117: `Screen' does not contain a definition for `width'

Then after that, I have no I2 Localization menu in Tools...I literally have nothing in there.

I am running Unity 2018.2.8f1

Thanks in advance!

Kevin

Please Log in or Create an account to join the conversation.

More
8 months 3 hours ago #3299 by Frank
Hi,
Thats weird, Unity's Screen does have a definition for width.
So, I'm guessing something was corrupted when installing.

My advice is to Delete the I2 folder. Wait for your game to compile correctly. Then install the package again.
BTW, are you using 2.8.9 or 2.8.10?

Then after that, I have no I2 Localization menu in Tools...I literally have nothing in there.


That's expected, if you are having compile errors, then the menu commands were not compiled either, so nothing will show, not event the language sources.

Please let me know, if reinstalling the package worked, and what version of I2 Localization are you using.
Thanks,
Frank

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
7 months 4 weeks ago #3301 by kevinbedard
I am using 2.8.9 f1 of I2 Loc, which is the only one available in the Unity Asset Store. I did the re-install as well and it's the same exact thing happening. Should I try installing it another way then from the Unity Store?

Should I not use that one and if not, where should I be able to find the 2.8.10?

Thanks a lot for your quick answer!

Kevin

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #3313 by daniel
Some wired cases where this could also happen:

1. Unity did not install correctly (rare but possible)
2. There is another Screen Class in your Project

As Frank said, first remove all lately added Libraries and be sure the project Compiles and is running after removal. Then add one after another Plugin and Check after each if its running. Check always for Unity specific names that might be used by external Addon's.

Please Log in or Create an account to join the conversation.

Time to create page: 0.154 seconds
Template by JoomlaShine