Welcome, Guest
Username: Password: Remember me

TOPIC: Failing to import a CSV in any other than UTF8

Failing to import a CSV in any other than UTF8 1 week 3 days ago #3287

Hi all,

Sorry in advance for this really stupid question. I was using until now the default UTF8 import for my CSV files on Windows / Unity 2018.2.5.

I have noticed some characters replaced by 0xFFFD in my strings probably because some exotic characters (backquote, triple point) do not exist in UTF8.

When I try to export in UTF16 or UTF32, I2 Localisation says than I have a bad spreasheet format, missing key, type desc. But the format is the same as for the UTF-8 import, which works fine. Please find attached a fraction of the csv file.

What am I doing wrong? Do I need to recreate a new resource file?

Thanks!
Attachments:
The administrator has disabled public write access.

Failing to import a CSV in any other than UTF8 1 week 1 day ago #3291

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1139
  • Thank you received: 243
  • Karma: 72
Hi,
I'm not seeing any issue in the CSV file you attached. Am I missing something there?
I tried Importing the CSV into I2 Localization v2.8.9 and it worked fine, (English has the translations, and the French and German are empty, which matches the content of the CSV file).

Could you please attach or email me your I2Languages.asset so that I try exporting it to CSV and see if I can reproduce the wrong characters?
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.
Time to create page: 0.230 seconds
Template by JoomlaShine