Welcome, Guest
Username: Password: Remember me

TOPIC: How to test in edit mode

How to test in edit mode 3 weeks 9 hours ago #3276

  • LesB
  • LesB's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hello,

I can't seem to figure out how to test and view translations in edit mode. When I add the I2_Localize component, it modifies the TMP_Text string to have "<!-Missing Translation [ XX ]-!>" surrounding the actual text. From there, the only way I can view the TMP_Text is when running in play mode. This makes it difficult to build Ui layouts. I presume I just haven't figured out how to use it properly in edit mode yet.

Thank you
Les
The administrator has disabled public write access.

How to test in edit mode 3 weeks 9 hours ago #3277

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1139
  • Thank you received: 243
  • Karma: 72
Hi,
It should work the same in Edit or Play mode.
If you are getting Missing Translation, it means that the Term for the current language has no translations.

You need to verify that:
- The localize component has the right Term assigned
- The Term has a valid translation (not empty) for the current language.

Also, notice that the Editor language can be different that the language you have selected to play. To be sure you have the right language, you can open the Languages Tab in the I2Languages.asset and click "Show" in English or any other language.
That will set the current language to that one, and will update all Texts to have the correct translation.

Also verify that all your translations are in the I2Languages.assets. If instead, you are using a local LanguageSource (instantiated in a scene), then the Localize component should have a reference to that source (at the bottom of the component inspector)

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.

How to test in edit mode 3 weeks 9 hours ago #3278

  • LesB
  • LesB's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Frank wrote:
Hi,
To be sure you have the right language, you can open the Languages Tab in the I2Languages.asset and click "Show" in English or any other language.
That will set the current language to that one, and will update all Texts to have the correct translation.
This is what I was trying to find. Thank you.

Frank wrote:
If you are getting Missing Translation, it means that the Term for the current language has no translations.
The translations are all there. I suspect it has something to do about hitting 'Translate' one at a time vs hitting 'Translate All'. It doesn't seem to matter as much though now that I know how to test in edit mode.

Thank you for the speedy reply.
The administrator has disabled public write access.
Time to create page: 0.240 seconds
Template by JoomlaShine