Help needed: Wrong translations in app

More
7 months 3 days ago - 7 months 3 days ago #3267 by ellen
Hi,

I have 5 different languages and they all work as expected in Unity. But when I build to Android they get all mixed up. I get some terms translated correctly, and some into other languages, and also some into older translations I have written new ones for - all mixed up in the same scene. I don't use Google Spreadsheet so I can't use the fix I read in some other topic here. I tried updating to latest version, 2.8.8 but problem persists. How do I fix this?

Respectfully,
Ellen
Last edit: 7 months 3 days ago by ellen.

Please Log in or Create an account to join the conversation.

More
7 months 2 days ago #3268 by ellen
Seems to be the unloading of languages in runtime causing the problems. I set it to never and now I think it works as expected :)

Please Log in or Create an account to join the conversation.

More
7 months 2 days ago #3269 by Frank
Hi,
The problem with the terms showing mixed/shifted in the device was corrected a couple versions ago. However, if you are still seeing it or a similar one, it means there maybe a case that still produces this bug.
I will help a lot if you could email me your I2Languages.prefab. I will test it myself and see why it's happening for you so that you could re-enable the Unload languages.

Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #3288 by ellen
I have emailed you the prefab a couple of days ago

Please Log in or Create an account to join the conversation.

Time to create page: 0.140 seconds
Template by JoomlaShine