Welcome, Guest
Username: Password: Remember me

TOPIC: Changing TMPro font changes texts to font name

Changing TMPro font changes texts to font name 8 months 1 week ago #2903

Hi, I try to set different font assets for chineese and russian language. But I have some troubles, because when I'm trying to assign TMP font to the term, the font isn't changing but text is changing to font name.

As you can see on screen below, I have term in many languages, but for russian and chineese after changing a font, there are font names, instead of proper term in these languages:
The administrator has disabled public write access.

Changing TMPro font changes texts to font name 8 months 1 week ago #2905

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1149
  • Thank you received: 248
  • Karma: 75
Hi,
From your screenshot, I see you are in an older version of I2 Localization.
You should update to the latest AssetStore version (or even better, download the 2.8.5 from the beta folder) There has been lots of changes around this.

Hope that helps,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.

Changing TMPro font changes texts to font name 8 months 1 week ago #2907

Thanks for your help, newest version from asset store didn't solve the problem, I will try beta release.
Last Edit: 8 months 1 week ago by TadeuszSynZygmunta.
The administrator has disabled public write access.

Changing TMPro font changes texts to font name 8 months 1 week ago #2908

I upgraded plugin to 2.8.5 a4 version. It still changes my texts to font name, I'm making everything like it is showed in tutorial.

EDIT: It's weird because when i set the font to tmpro category, that font is set also as a child, object, texture, audioclip etc.
Last Edit: 8 months 1 week ago by TadeuszSynZygmunta.
The administrator has disabled public write access.

Changing TMPro font changes texts to font name 8 months 1 week ago #2910

  • Frank
  • Frank's Avatar
  • Offline
  • Administrator
  • Posts: 1149
  • Thank you received: 248
  • Karma: 75
Hi,
Can you please, email me or post some photos of how you have setup the translation for the labels that fail.
I mean: a photo of the Localize component in the Main term, another in the Secondary term (while in Editor mode), and another showing that in the last post about font also set as child, object, texture, etc.

Or even better, if you could duplicate the scene you have issues with and delete everything except for the terms that are failing. And send it to me along with the LanguageSource, I could take a look at the setup and give you a better a answer of why it is failing.

I double checked the TextMeshPro example scene and the font and text are changing correctly there, so I'm guessing its a setup issue which should be easy to fix.

Thanks,
Frank
Are you :-) Give I2L 5 stars!
Are you :-( Please lets us know how to improve it!
To get the betas as soon as they are ready, check this out
The administrator has disabled public write access.
Time to create page: 0.138 seconds
Template by JoomlaShine