Bug: I2Utils FindNextTag doesn't handle Nested Tags causing

More
9 months 1 week ago #4192 by UltraRat
If ApplyRTLfix has a string with multiple types of tag starters like <!-Missing [TermName]-!> an IndexOutOfRangeException is fired because FindNextTag marks < as the tag start and ] as the tag end which can't restore the tags correctly.

I've worked around it for now, just reporting it since I didn't see it anywhere.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago - 3 months 1 week ago #4330 by nindim
Hi,

I think we are hitting the same error when switching to Arabic. The cause seems to be having a missing string in the game.
IndexOutOfRangeException: Index was outside the bounds of the array.
  at I2.Loc.LocalizationManager.ApplyRTLfix (System.String line, System.Int32 maxCharacters, System.Boolean ignoreNumbers) [0x00132] in XXX\Assets\I2\Localization\Scripts\Manager\LocalizationManager_RTL.cs:60 
  at I2.Loc.Localize.OnLocalize (System.Boolean Force) [0x003ad] in XXX\Assets\I2\Localization\Scripts\Localize.cs:224 
  at I2.Loc.Localize.OnEnable () [0x00001] in XXX\Assets\I2\Localization\Scripts\Localize.cs:145 

It would be great to get this fixed as it's firing a lot during development.

Thank you!

Software Versions
Unity 2018.4.23
Text Mesh Pro: 1.5.0 Preview 11
I2 Localization: 2.8.13 f2
Last edit: 3 months 1 week ago by nindim.

Please Log in or Create an account to join the conversation.

Time to create page: 0.219 seconds
Template by JoomlaShine